Back to overview
Downtime
Downloader and Randomizer are down
Mar 23 at 11:13pm CET
Resolved
Mar 23 at 11:56pm CET
Working correctly for now
Affected services
Created
Mar 23 at 11:13pm CET
We are investigating the cause of the issue
Affected services